Technology Requirements

System Requirements

This course is reliant on video. A broadband internet connection is highly recommended.

Browser Requirements for Video

To play the videos in this course you must have:

  • A web browser with Adobe Flash 9 plugin or greater installed.

- OR -

One of the following web browsers, which support HTML5 H.264 video.

  • Internet Explorer 9 and above
  • Safari 3 (Mac OS) and above
  • Safari 3.1 (iPad) and above
  • Android 3 and above

Preferred Browsers for Viewing

The following is a list of preferred web browsers for viewing course content.

The web browser you use must have Javascript turned on.

  • Safari 4 and above
  • Internet Explorer 8 and above
  • Firefox 5 and above
  • Chrome 10 and above
  • Opera 10 and above
  • iPad with Safari 3.1 and above

You may be able to successfully view the course with other web browsers.

Helpful links

How to get help

Begin Course